Forums

Please or Register to create posts and topics.

Hi

Hello everyone,

 

I just stumbled on this site looking for War2 content on the net. Around the end of the year, me and a pal of mine typically get the urge to play some dedicated coop maps vs comps. I used to play some vs in the old Bnet days as well.

I still remember the day I got the original game way back in 95. Warcraft 2, Diablo 1 & 2 and Starcraft are for me the classics I always return to.

The last few years, we've found it impossible to connect to Bnet. I then found out that Blizzard relinquished its game to GoG. So I bought the game for the 3rd time, but we haven't tested it yet.

Nice to see a friendly environment for War2 multiplayer. Seeing the content on the site and the various user-created maps makes me believe you have something special going here and I want to see if I can be a part of it.

I downloaded the game from the site. My anti-virus removed LC.dll believing it's a ransomware-type trojan (anyone have that too ?). I had to install the .reg file to see the server list. I could connect to the server.

What times do you usually play ? Any EU-friendly hours ?

Warm seasonal greetings from Belgium !

Cheers,

Gil.

 

Welcome, take a look at this thread for the GOG question.

http://war2usa.com/index.php/forums/topic/gog-version-on-war2usa-reg-file/#postid-1663

The LC.DLL will modify the client so you can pull peons and have the mods most war2 players use. If you noticed the other clients have inherited this .dll. I set an exclusion for the LC.dll you may or may not do the same. If you would like some more verbose information @lambchops

Cya around if you have any issues or questions let us know.

Thanks! Tupac Administrator

@Tupac : I was afk in the War2USA channel (actually browsing the forums here heh) when you came by and let me know of the reg file. Thanks for the heads-up ! Sorry I wasn't able to answer you when you were on.

 

I since read a bit more about setting up the WAR2USA client. I set an exclusion for the LC.dll file (since it was removed by the antivirus, I just created it again as an empty file) and then uninstalled/reinstalled the client. After reinstalling the client, the server list was populated so I didn't have to run the registry file manually.

I'm not sure if the plugins are working. In the folder C:\Warcraft II BNE\plugin I see :

AutoWarlatNM.w2p

chop_bars.w2p

CpuSaveC.w2p

fastMM.w2p

game_time.w2p

lobby_map.w2p

MMblack.w2p

I tested creating a game on the server, but didn't see a minimap in the lobby. Is there anything special I must do to activate these plugins ?

Cheers,

Gil.

 

Quote from Gillias on December 28, 2020, 5:24 pm

@Tupac : I was afk in the War2USA channel (actually browsing the forums here heh) when you came by and let me know of the reg file. Thanks for the heads-up ! Sorry I wasn't able to answer you when you were on.

 

I since read a bit more about setting up the WAR2USA client. I set an exclusion for the LC.dll file (since it was removed by the antivirus, I just created it again as an empty file) and then uninstalled/reinstalled the client. After reinstalling the client, the server list was populated so I didn't have to run the registry file manually.

I'm not sure if the plugins are working. In the folder C:\Warcraft II BNE\plugin I see :

AutoWarlatNM.w2p

chop_bars.w2p

CpuSaveC.w2p

fastMM.w2p

game_time.w2p

lobby_map.w2p

MMblack.w2p

I tested creating a game on the server, but didn't see a minimap in the lobby. Is there anything special I must do to activate these plugins ?

Cheers,

Gil.

 

Not a problem at all. I'm glad you seen my message. So if you added an exception or exclusion for the lc.dll. verify the .dll is in the war2 folder. Also the USA installer will allow you to customize your mods, enable, disable, etc. But yeah other then that, it should work.

Thanks! Tupac Administrator

Last night, I could connect to the server, but not join games. Each time I tried to join, the game would freeze for a second and then close. I was able to host and have others join the lobby.

Tupac generously spent some of his time looking at the problem. We determined that although I have the correct LC.dll in the game directory, the LC plugins were not active, as there was no minimap for me in the lobby. Also, on the main screen, there was no mention of them in the bottom right corner.

I tried to exclude LC.dll on my anti-virus, but that didn't fix the issue. Tupac noticed that my anti-virus (provided by my ISP, based on F-Secure) was similar to a previous anti-virus of his that also refused to let things work.

I then switched off briefly the anti-virus protection and then tried to start War2. There was still no mention of the plugins. Uninstall/reinstall of War2USA : same problem.

I then opted for another anti-virus from my ISP and uninstalled the F-Secure anti-virus, followed by a reboot and reinstall of War2USA. Still no plugins mentioned, no minimap while in the game lobby.

Configuring the plugins in the installer shows that at least ddraw.dll is working : with the ddraw plugin active, I can start the game and switch between windowed mode and fullscreen mode. With the plugin inactive, War2 gives an error about the screen resolution being incorrect.

It seems LC.dll won't work for me. Any ideas on what more I could try ?

Cheers,

Gil.

 

@Tupac : I renamed LC.dll in the game directory and then downloaded your LC.dll from discord (which now does not pose a problem anymore with F-Secure uninstalled) and put that LC.dll in the game directory. Still no mention of the plugins on the main screen.

Cheers,

Gil.

 

 

Okay, I think I solved my problem finally.

As I don't like stuff cluttering my desktop, I had deleted the shortcut that the installation placed there. I was starting the game each time by clicking on the Warcaft II BNE.exe in the game directory (force of habit).

I then noticed the launcher.exe in the game directory and started that. Kaboom : plugins mentioned in the bottom right corner. I went on the server and created a test game. Sure enough, there was the minimap in the lobby, the game timer on the minimap, grey colour for black on the minimap.

I then checked the properties of the shortcut (after reinstalling) : it points to launcher.exe of course.

So, all's well that ends well !

Cya in a game sometime 🙂

Special thanks to iz7z, MFCS and Tupac for welcoming me and being involved in testing and solving the issue.

Cheers,

Gil.